Xiaomi Gateway Firmware Update => Gateway crashed & neue Sensoren hinzufügen nicht möglich

  • Hallo zusammen,

    ich habe mir vor gut drei Wochen ein Xiaomi Gateway (Typ DGNWG02LM) und den runden Temperatursensor von Xiaomi bei Aliexpress bestellt.

    Ich habe mit diesem zwei Probleme, nachdem ich erfolgreich den Temperatursensor gepaired habe:

    Direkt nach dem Pairing meldete die SteuerApp auf dem iPad (Mi Home v4.7.1), dass eine neuere Firmware für das Gateway verfügbar sei:

    * aktuelle Firmware: 1.3.1_140.0143

    * angebotenes Update: 1.3.1_141.0143

    Wenn ich das Update durchführe, lädt er es komplett herunter (Fortschritt geht bis auf 100%, anschließend erscheint install und diese Anzeige bleibt für ca. 3 Minuten. Danach Zeigt er dasselbe Update erneut an, sprich das Update wurde nicht durchgeführt. Leider keine Fehlermeldung und ein Error Log des Gateways habe ich in der App leider auch nicht gefunden.


    Als ich mir meine Grundausstattung (Gateway und Temperatursensor) gekauft hatte, hatte mich das fehlgeschlagene FIrmware Update

    erst einmal nicht gestört.


    Direkt danach habe ich nun einen weiteren runden Temperatursensor, die eckigen Türsensoren (Aqara-Version) und den Bewegungsmelder (Aqara-Version) gekauft. Diese sind gestern angekommen und ich wollte sie mit dem Gatway pairen.

    Das schlug aber bei sämtlichen Sensoren fehl, weshalb ich dachte, mich des Firmware-Updates noch einmal anzunehmen, falls die Sensoren eine neuere Firmware benötigen. Der Prozess ist aber immer derselbe: Install wird angezeigt, dann passiert nichts mehr.

    Teilweise (jedes zweite bis dritte Mal) stürzt das Gateway dabei ab und ich muß es vom Strom trennen und wieder einstecken.


    Die üblichen Verdächtigen habe ich (glaube ich zumindest) ausgeschaltet:

    Als Location verwende ich Mainland - bei allen anderen Orten bekomme ich gar kein Firmware Update angezeigt.


    Auch wurde hier in einigen Threads empfohlen die App zu deinstallieren und neu zu installieren - das brachte bei mir auch keinen Erfolg.


    Der bereits mit dem Gateway verbundene Temperatur-Sensor kann einwandfrei von ioBroker (verwende ich als Zentrale) ausgelesen werden und die damit verknüpften Skripte laufen ebenfalls einwandfrei.


    Leider habe ich auch nirgends ein Error Log für das Gateway gefunden, weshalb ich gerade nicht weiter weiß.


    Hat jemand einen Tipp für mich?


    Schon einmal vielen Dank im Voraus!


    Gruß Sascha

  • Heute früh hatte ich die Möglichkeit, es mit einem Android Gerät zu versuchen (von Moto, letztes Baujahr, daher vermutlich als Fehlerquelle bzgl. nicht aktueller Software ausschliessbar - hatte leider vergessen die Software-Version zu notieren).

    Leider das gleiche Spiel: Update wird angezeigt (gleiche Firmware Revision, wie auf dem iPad), Update beginnt und er sagt es wäre fehlgeschlagen.

    Habe es jetzt auch noch mal vom iPhone probiert (gleiche Version wie das iPad) - gleiches Verhalten.


    Wenn nicht noch jemand eine gute Idee hat, versuche ich es einmal mit einem Factory Reset. Habe davon aber bisher Abstand genommen, aufgrund der hier geschilderten Probleme:

    http://en.miui.com/thread-223887-1-1.html

  • Update: Habe das Gateway, wie unter http://en.miui.com/thread-223887-1-1.html (Seite 6, Beitrag von ibebbs) auf die Factory Defaults zurückgesetzt. Den bereits existierenden Temperatursensor und das Gateway habe ich vorher aus der App manuell entfernt - scheint auch ein korrektes "Depairing" zu sein, da nach dem Entfernen des Gateways in der App der organgene Ring zu blinken anfing.

    Gateway anschließend wieder zur App hinzugefügt. Firmware Update ausprobiert -> gleiches Phänomen. Ab und an auch hier ein Absturz des Gateways.

    Alten (den den ich vor drei Wochen bestellt hatte) Temperatursensor gepaired - funktionert.

    Neuen Türkontakt gepaired - funktioniert nicht. Neuen Body-Sensor? (also den Bewegungsmelder) gepaired - funktioniert nicht. Beide habe ich in zweifacher Ausführung und zwar die Miju-Variante. Dasselbe Problem mit allen Vieren.
    Heute ist noch ein zweiter Temperatursensor gekommen. Gepaired - und hat sofort funktioniert...
    Jetzt stelle ich mir die Frage, ob es an den Sensoren oder am Gateway liegt. Das Gateway ist wie oben an der Modellnummer zu sehen, sowohl für die Mi als auch Miju Sensoren geeignet (zumindest habe ich es so verstanden). Die Ausstattung lässt das auch vermuten: Licht-Ring, China-Radio integriert.

    Gibt es irgendwo eine Übersichtsseite, wo ersichtlich ist, welcher Sensor ab welcher Version der Gateway-Firmware läuft? Könnte ja auch sein, dass die Temperatursensoren mit meiner Version laufen, die Bewegungsmelder und Türkontakte hingegen nicht...


    Ich stehe gerade auf dem Schlauch...

  • Ich habe genau das selbe Problem und alles erdenkliche Probiert. Die Runden Temparatursensoren und Fensterkontakte konnte ich pairen. Auch den Bewegungssensor ohne Lichterkennung. Den von Aqara aber wiederum nicht. Habe das Update mit dem iPhone X und dem Redminote 4 probiert. Beides klappt wie von dir auch beschrieben nicht. Hast du inzwischen eine Lösung gefunden?


    Update: bei mir steht im W-LAN beim connecten mit dem Gateway: lumi-gateway-V3

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Adventado ()

  • Um dem Problem weiter auf den Grund zu gehen, hatte ich einen Satz Fenstersensoren Xiaomi Mi Door Window Sensors (die mit den abgerundeten Ecken) bestellt, welche gestern angekommen sind.

    Sie lassen sich sofort mit meinem Gateway pairen und ansprechen.


    Zusammengefasst:

    • Die Firmware des Gateways lässt sich nicht updaten.
    • Mi-Sensoren (Fensterkontakt rund, Temperatursensor rund) lassen sich anlernen.
    • (Mijia) Aquara Sensoren (Aqara-Sensoren (Fensterkontakt eckig, Bewegungsmelder, Water Leak Detection Sensor) lassen sich NICHT anlernen


    Daher vermute ich, dass mein Gateway wirklich nur mit Mi und nicht mit mijia/Aquara Sensoren arbeiten will.

    Da zudem die Firmeware nicht aktualisierbar ist, tippe ich stark auf einen Defekt des Gateways - oder gibt es noch eine Zwischenversion zwischen dem Gateway V1 und V2, welches nicht mit Mijia Aquara Sensoren arbeiten kann? Auf gut Glück möchte ich aber kein neues Gateway bestellen.


    Folgende Fragen/Bitten/Ideen:

    1. Kann sich hier kurz jemand zu Wort melden, bei dem die Aquar/Mija-Sensoren an dem Xiaomi Gateway 2 einwandfrei funktionieren? Wenn ja:
    2. Besteht eventuell die Möglichkeit bei jemandem aus dem Raum Köln, meine Miju/Aqara-Sensoren, an dessen Gateway einmal auszuprobieren?


    Schon einmal vielen Dank im Voraus für weitere Tipps / Hilfe.