Workaround: Alarmanlage mit zeitverzögertem Alarm und Ausschaltknopf

  • Hat der Workaround bei dir funktioniert? 0

    1. Ja (0) 0%
    2. Nein (0) 0%
    3. Uninteressant (0) 0%

    Aufgrund des großen Interesses hier nun als eigener Thread (nicht nur als Subpost):


    Da Xiaomi/Aqara keine echte Alarmanlagenfunktion mit Codeeingabe zur zeitverzögerten Deaktivierung bietet, habe ich mir einen funktionierenden Workaround ausgedacht - hat mich Hirnschmalz gekostet. Der Workaround lässt sich sowohl mit Android als auch iOS einrichten.


    Ziele:

    • Einfache Aktivierung und Deaktivierung der Alarmanlage für alle Familienmitglieder ermöglichen (nicht nur über die Mi App).
    • Physische Aktivierung der Alarmanlage über einen Wireless switch.
    • Physische Deaktivierung der Alarmanlage über denselben Wireless switch mit einer Zeitverzögerung (bspw. 1 Minute) bevor der Alarm nach dem Öffnen der Tür akustisch losgeht.


    Hier das ganze Setup:


    Scene 1

    If complete manually

    Then Enable arming mode (am Gateway unter control arming)

    Name: "Gateway - Aktiviere arming mode"


    Scene 2

    If complete manually

    Then Disable arming mode (am Gateway unter control arming)

    Name: "Gateway - Deaktiviere arming mode"


    Einstellungen am Gateway:


    Auto -> Alert

    Alert Trigger Device einstellen (also den Smart door/window Sensor)

    Delay: 60 Sekunden

    Unter More settings: Alarm volume auf 0 stellen (nicht wundern jetzt!) + Alert time -> Custom 1 Sec

    Linkage alarm: andere Gateways linken, falls vorhanden, damit der Alarm auch schön laut wird


    Nun der Alarm Workaround:

    Damit geht der "normale" Alarm des Gateways (nicht der des arming modes, der ist ja stumm) nach 1 Minute an.


    Automation

    If Alarm (am Gateway)

    Then

    Delay 1min

    + Play designated ringtone (am Gateway -> Lautstärke hoch einstellen)

    + Send notification to device (unbedingt einrichten, Erklärung am Ende)

    Name: "Hörbarer Alarm"


    Damit der Alarm nicht ewig läuft eine weitere Automation (Achtung, noch nicht getestet):

    If alarm (am Gateway)

    Then

    Delay 11 min

    + Turn on/off an automation -> "Hörbarer Alarm" -> Turn off



    Zwei Automationen mit dem Wireless switch (der Alarmknopf an der Tür):


    1. Automation:


    If Single press (am Wireless switch)

    Then

    Run automation "Gateway - Aktiviere arming mode" (= Scene 1)

    + Turn on/off an automation -> "Hörbarer Alarm" -> Turn on


    Name: Aktiviere arming


    Damit werden der "normale Alarm" und der "hörbare Alarm" aktiviert.



    2. Automation:


    If double press (am Wireless switch)

    Then

    Run automation "Gateway - Deaktiviere arming mode" (= Scene 2)


    + Turn on/off an automation -> "Hörbarer Alarm" -> Turn off


    Name: Deaktiviere arming


    Damit werden der "normale Alarm" und der "hörbare Alarm" deaktiviert, und man hat durch die Automation "Hörbarer Alarm" 60 Sekunden Zeit dazu.


    Mühsam zum Einrichten, aber es funktioniert bestens.


    Einziges Manko: Man bekommt immer eine Nachricht, wenn die Tür aufgeht, weil sich am Gateway die Funktion "push alarm message via mobile phone" leider nicht abstellen lässt. Aber: Bekommt man nach 1 Min. eine zweite (!) Nachricht, heißt das, dass der "hörbare Alarm" losgegangen ist (weil der Wireless switch nicht innerhalb von 1 Min. doppelgeclickt wurde).


    Viel Spaß beim Ausprobieren!

  • Danke Sakala, werd ich morgen gleich mal durchprobieren. :)


    Ich habe grad auch noch eine gute Möglichkeit in einem Forum gefunden, wie man den Alarm "verzögern" kann vielleicht nutzt es dem EInen oder Anderes was.

    Also man erstellt sich einfach einen Sound z.B mit dem kostenlosen Tool: Audacity und fügt vor dem eigentlichen Sound einfach eine Stille ein, je wie lange man es haben möchte, bis der Sound losgehen soll. Klappt wunderbar.


    Wenn ich nun die Alarmanlage scharf schalte und es wird ein Sensor ausgelöst, bekomme ich einen Alarmmeldung auf dem Handy und kann nun, wenn ich grad heim komme und vergessen hab, das die Alarmanlage ja an war, reagieren. Sollte ich (in meinem Fall 20 Sekunden Stille eingefügt) nicht reagieren geht der Alarm los und einen weitere Nachricht lasse ich mir zu diesem Zeitpunkt auch nochmal schicken.



    ###### Nachtrage #####

    Wenn ich Deinem Workaround folge, kann ich einfach nichts auswählen an dieser Stelle:


    + Play designated ringtone (am Gateway -> Lautstärke hoch einstellen)


    Muss ich da noch was hochladen oder was sollte man da sehen?

  • Auch eine coole Idee. Ich habe mich nur noch nicht getraut einen eigenen Sound hochzuladen, da ich in anderen Foren gelesen habe, dass da massive Probleme auftreten können - bis hin dazu, dass kein Sound mehr geht, auch nicht nach einem Reset.

  • Oh, puh na bei mir hat alles geklappt. Hab mir gestern noch 8 neue Alarmtöne hochgeladen. Problem hier ist aber, das die 2. Benachrichtigung trotzdem kommt, egal ob ich rechtzeitig die Alarmanlage deaktiviere. Haste da noch ne Idee?

  • @Nachtrag:

    Nochmal die Szene Hörbarer Alarm erklärt:

    If Gateway

    Then

    1 min later


    Add -> play designated ringtone -> in der Liste das Gateway auswählen -> Play designated ringtone -> nochmal play designated ringtone auswählen und dann kommt das Menü mit den Tönen (siehe Bild)

  • Hi Sakala,

    danke nochmal für die Anleitung, aber bei mir geht es einfach nicht. Befolge deine Anleitung und komme bis:

    Add -> play designated ringtone -> in der Liste das Gateway auswählen

    Klicke ich jetzt nochmal auf "Play designated ringtone" spingt er einfach wieder auf einen Stelle zurück.

    Ich probiere das heute Abend nochmal am iPhone.

  • Hallo Sakala,


    Habe alles eingestellt wie beschrieben. Leider geht der hörbare Alarm immer an (nach dem Delay) , obwohl die Scene nach Auftreten eines Alarms durch das Doppeldrücken ausgeschaltet (deaktiviert) sein müsste.

    Irgend eine Idee woran es liegen könnte?

    Danke und Gruß,

    cc

  • Hallo, super Idee und dank für die Mühe ;)

    Nun zu meier Frage:

    Ich habe ein recht großes Haus über zwei Stockwerke. Deshalb überlege ich mir für jedes Stockwerk einen Gateway und diese dann zu verbinden................würde das funktionieren ?


    lg und vielen Dank im voraus


    Tom

  • so, zweiter Gateway ist hier und die Fenstersensoren im Keller bei diesem angelernt.

    Muss ich nun bei diesem Gateway einfach den zweiten Vorgang:

    Einstellungen am Gateway:


    Auto -> Alert

    Alert Trigger Device einstellen (also den Smart door/window Sensor)

    Delay: 60 Sekunden

    Unter More settings: Alarm volume auf 0 stellen (nicht wundern jetzt!) + Alert time -> Custom 1 Sec

    Linkage alarm: andere Gateways linken, falls vorhanden, damit der Alarm auch schön laut wird


    bei diesem mit den entsprechenden Sensoren eingeben und das wars ?


    lg und vielen Dank


    Tom

  • Beim besten Wissen, Gewissen und langem Herumprogrammieren hat bei mir dieses und andere Workarounds für eine Eingangsverzögerung nicht geklappt. Es kann sein, dass die neueren Gateways nicht mehr so reagieren wie die alten - in meinem Fall konnte ich den hörbaren Alarm nicht mehr stoppen sobald er ausgelöst wurde.


    Für mich war letztendlich die einzig sinvolle Lösung, die Verknüpfung mit dem Home Assistant auf einem Raspberry Pi - vorausgesetzt man traut sich ein paar Zeilen (automations) zu programmieren. Die Dokumentation im Netz ist sehr ausführlich und man hat die volle Freiheit und Kontrolle über das Gateway und seine Aktoren. Kann ich wärmstens empfehlen.

    Wahrscheinlich ist das ein Grund warum Xiaomi sich nicht bemüht die armseelige Alarmfunktion zu verbessern.


    Gruß,


    c

  • Hmmm.

    Also bei mir funktioniert das wunderbar. Sobald ich die Wohnung verlasse und das Sherlock M1 verschlossen hat, aktiviert sich der Alarm. (auslösung über Türkontakt/Bewegungsmelder)

    Nach dem öffnen mit Sherlock deaktiviert sich der Alarm auch sofort Automatisch.

    Geräte: Sherlock M1, Gateway, Türkontakt, Bewegungsmelder, Schalter, Temperatur und Feuchtigkeitssensor, Cube, Netzdose mit Stromüberwachung, 2 Jeelight Color, Mi 5

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Maikels ()